Python 2 support
Scipy 1.2.2 is the last version to support Python 2. In particular, it requires Python >= 2.7. Starting 1.3.0, it requires Python >= 3.5
- This is also mentioned in Scipy 1.3.0 release notes - https://scipy.github.io/devdocs/release.1.3.0.html . Search for "#9582: MAINT: drop Python 2.7 and 3.4"
- https://heydenberk.com/blog/posts/sparse-matrix-representations-in-scipy/ - Sparse matrix representations in scipy